[Bro-Dev] Some bro.bif issues
vallentin at icir.org
Sun Nov 20 18:00:05 PST 2011
On Nov 18 2011 at 21:11PM PST, Gregor Maier wrote:
> > function active_connection%(id: conn_id%): bool
> > function connection_exists%(c: conn_id%): bool
> > are essentially the same. Only the latter is used in the current set of
> > scripts. Should we get rid of the former?
> sounds good. The latter is also the more intuitive name....
> > The same sort of redundancy exists for:
> > function connection_record%(cid: conn_id%): connection
> > function lookup_connection%(cid: conn_id%): connection
> > except that the latter returns a dummy connection value. Neither function is
> > currently used at script land. My vote would be to remove the former one, as
> > the latter has more graceful semantics.
> We for sure shouldn't call exit() when the connection doesn't exist...
Do others have any objections? Otherwise I would go ahead an remove
More information about the bro-dev