[Bro] Cant build Bro current on freebsd 6.1

dkalpakis at upnet.gr dkalpakis at upnet.gr
Wed Jul 5 19:50:06 PDT 2006

> On Mon, 2006-07-03 at 21:41 +0300, dkalpakis at upnet.gr wrote:
>> Neither trying "make distclean" nor fetching a fresh copy of the archive
>> worked ...:( I m still getting the same error, without seeing any other
>> messages before it.
>> Is there a possibility that there is something wrong/broken with the
>> archive of current Bro 1.1? Has anyone succeeded to build it recently,
>> using this specific archive? Any other suggestions?
> Could you upload somewhere a complete transcript of your configure run
> and build process? (The mailing list will likely complain about them
> being too big.) As Robin says, the missing files are generated during
> the build. Double-check whether the following appear during the build --
> maybe the problem is not visib;e error messages but rather the lack of
> them...
> source='bif_lex.cc' object='bif_lex.o' libtool=no \
> depfile='.deps/bif_lex.Po' tmpdepfile='.deps/bif_lex.TPo' \
> depmode=gcc3 /bin/sh ../depcomp \
> g++ -DHAVE_CONFIG_H -I. -I. -I..  -I. -I../src/binpac -I../src -I. -I..
> -Ilibedit  -I../linux-include -O -W -Wall -Wno-unused -I../linux-inclu
> de  -g -O2 -c -o bif_lex.o `test -f bif_lex.cc || echo './'`bif_lex.cc
> source='bif_parse.cc' object='bif_parse.o' libtool=no \
> depfile='.deps/bif_parse.Po' tmpdepfile='.deps/bif_parse.TPo' \
> depmode=gcc3 /bin/sh ../depcomp \
> g++ -DHAVE_CONFIG_H -I. -I. -I..  -I. -I../src/binpac -I../src -I. -I..
> -Ilibedit  -I../linux-include -O -W -Wall -Wno-unused -I../linux-inclu
> de  -g -O2 -c -o bif_parse.o `test -f bif_parse.cc || echo
> './'`bif_parse.cc
> source='bif_arg.cc' object='bif_arg.o' libtool=no \
> depfile='.deps/bif_arg.Po' tmpdepfile='.deps/bif_arg.TPo' \
> depmode=gcc3 /bin/sh ../depcomp \
> g++ -DHAVE_CONFIG_H -I. -I. -I..  -I. -I../src/binpac -I../src -I. -I..
> -Ilibedit  -I../linux-include -O -W -Wall -Wno-unused -I../linux-inclu
> de  -g -O2 -c -o bif_arg.o `test -f bif_arg.cc || echo './'`bif_arg.cc
> g++  -g -O2   -o bifcl  bif_lex.o bif_parse.o bif_arg.o  -Llibedit -ledit
> -lpcap -lpcap  -lssl -lcrypto -lpcap /usr/lib/libresolv.a -ltermcap
>  -lm
> ./bifcl ./bro.bif
> ./bifcl ./event.bif
> ./bifcl ./const.bif
> Is there an executable in the src/build directory called "bifcl" at the
> time the build breaks?
> Cheers,
> Christian.
> --
> ________________________________________________________________________
>                                           http://www.cl.cam.ac.uk/~cpk25
>                                                     http://www.whoop.org

Hi Christian,

I dont see any messages like those above during the build process and at
the time it breaks there isnt such executable called "bifcl". Right now I
am not able to upload somewhere the transcripts you asked for, so I ll try
to post them to the list. Because of the size limit (<40K) in the list I
ve attached to this message only the transcript of the configure process
(configure.txt - 11K). The transcript of the build process (make.txt -
34K) will be attached to the message that follows. Maybe you can find out
whats wrong with my system.

Thank you in advance...
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: configure.txt
Url: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20060706/082c874d/attachment.txt 

More information about the Bro mailing list