[Bro] bro on freebsd 7-RC1

Randolph Reitz rreitz at fnal.gov
Mon Mar 10 14:13:40 PDT 2008

On Mar 10, 2008, at   3:00, Paul Schmehl wrote:

> --On Monday, March 10, 2008 13:47:27 -0500 Randolph Reitz <rreitz at fnal.gov 
> >
> wrote:
>> On Mar 7, 2008, at   4:30, Paul Schmehl wrote:
>>> I'm the FreeBSD port maintainer for bro.  I'm running 7.0 RELEASE
>>> (i386), and
>>> I'm not having a problems compiling bro.  (I just compiled it after
>>> reading
>>> your email.)  Make sure that your sources, kernel and ports are up
>>> to date and
>>> try it again.  Also, what architechture are you trying to compile
>>> on?  I'm
>>> running i386 SMP.
>> I didn't notice the bro port.  Yes, the bro port compiles fine on
>> 7.0-RELEASE.  You get bro-1.2.1 which is the current stable  
>> release.  I was
>> trying to compile bro-1.3.2 which is the current development release.
>> Are FreeBSD ports made for development releases?
> In general, no.  FreeBSD devel ports are usually the libraries  
> associated with
> or required by a port.
> I thought about creating one for the devel release, but the problem  
> is, the
> code is constantly changing, so maintaining the port would be a  
> PITA.  It's
> much easier to maintain a stable release version.
> However, when I said "I'm not having any problems compiling bro", I  
> was
> referring to the 1.3.1 devel release that you were trying to  
> compile.  I
> downloaded and compiled it before posting my response.
> Did you ever say what ARCH you're running?
I have ...
[root at dtmb ~]# uname -a
FreeBSD dtmb.dhcp.fnal.gov 7.0-RELEASE FreeBSD 7.0-RELEASE #0: Sun Feb  
24 19:59:52 UTC 2008     root at logan.cse.buffalo.edu:/usr/obj/usr/src/ 
sys/GENERIC  i386

Humm, I tried to 'make install' bro 1.3.2 again and it worked.

[root at dtmb /home/rreitz/bro-1.3.2]# /usr/local/bro/bin/bro -v
/usr/local/bro/bin/bro version 1.3.2

I can't say what is different today from last Friday.  I thought that  
installing the bro port may have added a dependency, but that doesn't  
seem to be the case...

[root at dtmb /usr/ports/security/bro]# make depends
===>   bro-1.2_1 depends on file: /usr/local/bin/perl5.8.8 - found
===>   bro-1.2_1 depends on file: /usr/local/bin/perl5.8.8 - found
===>   bro-1.2_1 depends on executable: bison - found
===>   bro-1.2_1 depends on file: /usr/local/bin/perl5.8.8 - found
===>   bro-1.2_1 depends on file: /usr/local/bin/perl5.8.8 - found
[root at dtmb /usr/ports/security/bro]# whereis bison
bison: /usr/local/bin/bison /usr/local/man/man1/bison.1.gz /usr/ports/ 
[root at dtmb /usr/ports/security/bro]# ls -l /usr/local/bin/bison
-r-xr-xr-x  1 root  wheel  228028 Mar  5 14:37 /usr/local/bin/bison

Thanks for looking at this.  I'll install my 10GB network card and see  
what new trouble I can find.


> -- 
> Paul Schmehl (pauls at utdallas.edu)
> Senior Information Security Analyst
> The University of Texas at Dallas
> http://www.utdallas.edu/ir/security/
> _______________________________________________
> Bro mailing list
> bro at bro-ids.org
> http://mailman.ICSI.Berkeley.EDU/mailman/listinfo/bro

More information about the Bro mailing list