[Bro] No Work Dir Found

Sam Oehlert soehlert at ncsa.uiuc.edu
Fri Jul 23 11:03:17 PDT 2010


I managed to fix the no work dir found problem (silly permissions issues and ssh-keys). I run broctl check and everything says ok. I then try to start and everything starts ok, but then all of the workers immediately fail due to an error at line 67 of /usr/local/bro/share/bro/drop.bro 

internal error: NB-DNS error in DNS_Mgr::WaitForReplies (recvfrom(): Connection refused)

It doesn't make sense to me because it seems like it's saying it has DNS issues, but DNS works in every other aspect (ping, browser).

Sam

----- Original Message -----
From: "Justin Azoff" <JAzoff at uamail.albany.edu>
To: "Sam Oehlert" <soehlert at ncsa.uiuc.edu>
Cc: "bro" <bro at ICSI.Berkeley.EDU>
Sent: Friday, July 23, 2010 12:49:39 PM
Subject: Re: [Bro] No Work Dir Found

On Fri, Jul 23, 2010 at 01:39:14PM -0400, Sam Oehlert wrote:
> I have tried to read through all the documentation and whatnot, but I
> don't see anything about this topic. I have bro starting fine now,
> however, it always quits because it says no work dir found on all of
> the workers. Do I need to specify a directory for it to use? How do I
> do that?

did you run 'install' in broctl?

-- 
-- Justin Azoff
-- Network Security & Performance Analyst




More information about the Bro mailing list