[Bro] Help with swig dependency on FreeBSD 8.1

Paul Halliday paul.halliday at gmail.com
Thu Jan 5 16:00:09 PST 2012


A little OT but maybe someone can prod me in the right direction.

I am trying to build bro on FreeBSD 8.1. I get the following error:

Found swig version:
Found python version: 2.6

CMake Error at aux/broctl/aux/pysubnettree/CMakeLists.txt:26 (message):
  Swig versions less that 1.3.30 are incompatible with Python versions
  greater than or equal to 2.5, upgrading your swig installation is
  recommended.

Easy enough. I grabbed the latest version of swig (2.0.4) put I can't
seem to get around a pcre include error. I found a few threads online
but I am having no success.

This is the config error:

Swig/misc.c:1119:18: error: pcre.h: No such file or directory

which is sitting in /usr/local/include

so I tried:

~# ./configure --with-pcre-prefix=/usr/local/include

to no avail.

There is  a .sh in the tools dir for swig that is supposed to do a
static link. So I grabbed the most recent pcre tarball and tried this.
It goes through the motions yet when I run configure again I get the
same error.

I am probably missing something obvious here. Help!

Thanks.

-- 
Paul Halliday
http://www.squertproject.org/



More information about the Bro mailing list