[Bro] Trouble building Bro 2.2 on ARMv6 (Raspberry Pi / Wheezy)

Jonathan Ness jdness at mac.com
Sat Sep 28 21:51:15 PDT 2013

Hi, I have been using Bro 2.1 on my Raspberry Pi device.  It worked mostly out of the box.  (There was a small configuration change due to RPI's missing realtime clock but otherwise, worked fine.)  However, Bro 2.2 does not build on the same device.  It builds fine on the same configuration of Linux (Debian Wheezy) under Hyper-V on x64 so I suspect the ARM aspect of the RPI.  I haven't used cmake before so really I'm not even sure how to debug the build issue but here's stdout:

[  8%] [BIFCL] Processing top-k.bif

usage: bifcl [-p] *.bif

make[3]: *** [scripts/base/bif/top-k.bif.bro] Error 1

make[3]: Leaving directory `/home/pi/bro/build'

make[2]: *** [src/probabilistic/CMakeFiles/bif-alt-probabilistic-top-k.bif.dir/all] Error 2

make[2]: Leaving directory `/home/pi/bro/build'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/pi/bro/build'

make: *** [all] Error 2


I assume it's a problem with bifcl so I tried replacing the Bro 2.2 build tree bifcl with the one from the Bro 2.1 build tree but that didn't work either.  (different error when doing that:  "Error: cannot open file: -s")  Maybe it's an option mismatch...?

Has anyone gotten Bro 2.2 to build on ARMv6?  Any tricks / tweaks needed?  Thanks!


P.S.  The new work on file carving is fantastic!  Enables all kinds of interesting new scenarios!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20130929/53870a13/attachment.html 

More information about the Bro mailing list