[Bro] Error: cannot determine Bro version

Siwek, Jon jsiwek at illinois.edu
Thu Apr 9 07:48:41 PDT 2015


> On Apr 8, 2015, at 2:07 PM, Jerome Taylor <jtaylor1024 at yahoo.com> wrote:
> 
> I just completed a new Bro installation. I receive the following error message when I try to start Bro (i.e. "broctl | install").
> 
>     Error: cannot determine Bro version
> 
> My Setup:
> =======
> bro version 2.3-680
> minimum configuration => (a single Bro instance on the localhost)
> 
> Note: "bro -v" will return the version number but it also produces a segmentation fault..
> 
> I do not see this issue in older releases of Bro. Is there a known issue with this latest release?

No, that’s not been seen before and things appear to work fine on various platforms Bro is tested against.  Can you give more details?  What platform/OS/compiler?  Did you give any special ./configure flags?  Can you post a backtrace from gdb/lldb ?

> In what I believe is an unrelated issue, I notice that the file "/usr/local/bro/spool/broctl-config.sh" does not exist; 

I think that file is generated by `broctl install`, so if that doesn’t complete due to the issue you mention above, that could explain why it’s missing.

- Jon



More information about the Bro mailing list