[Bro] Bro installation

Johanna Amann johanna at icir.org
Tue Sep 22 09:09:40 PDT 2015

Hello Amina,

the current bro master installation from git.bro.org, that I think you are
trying to use, requires an installation of libcaf
(http://www.actor-framework.org). You either have to install it and
provide the location to configure using --with-libcaf=PATH, or tell
configure to disable the parts of Bro that need the library using

If you are trying to compile Bro 2.4.1, this should not be necessary.

As to the binary packages, I just tried an installation on a fresh CentOs
installation that worked without any problems. If you want help in
trouble-shooting that, please provide all steps that you followed until
you arrived at the error-message.

I did:
[root at test ~]# cd /etc/yum.repos.d/
[root at test yum.repos.d]# wget http://download.opensuse.org/repositories/network:bro/CentOS_6/network:bro.repo
[wget output]
[root at test yum.repos.d]# yum install bro
[yum output, succesful installation]
[root at test yum.repos.d]# /opt/bro/bin/bro --version
/opt/bro/bin/bro version 2.4.1
[root at test yum.repos.d]# cat /etc/centos-release 
CentOS release 6.7 (Final)

I hope this helps,

On Tue, Sep 22, 2015 at 11:50:52AM -0400, Amina Jackson wrote:
> I have CentOS 6.7. I have attempted to install bro in all possible ways 
> with no success. I have installed the dependencies and development tools 
> but I keep getting errors.
> The git installation yields an error
> When I try installing the binaries, I get 
>  Any help will be very appreciated. 

> _______________________________________________
> Bro mailing list
> bro at bro-ids.org
> http://mailman.ICSI.Berkeley.EDU/mailman/listinfo/bro

More information about the Bro mailing list