[Bro] Undefined symbol error while writing an analyzer

Luis Martin Liras martin.liras at gmail.com
Wed Apr 20 06:22:46 PDT 2016


I'm quite new in bro, and I'm trying to develop an analyzer as a plugin 
(Not an easy task), using the  modbus analyzer as a starting point.

I have passed through all the steps and everything seem to be OK: It 
compiled OK and Bro detects the plugin and its events when run with the 
-NN option

However when I try to register my analyzer:

Analyzer::register_for_ports(Analyzer::ANALYZER_UMAS, ports);

I get the following error:

../build/src/bro: symbol lookup error: 
<http://UMAS-UNITY.linux-x86_64.so>: undefined symbol: 

I have tried to make it simpler and simpler, but always crash against 
the same error. Even started a new analyzer from scratch, following the 
quickstarter guide (the SAMPLE one)... and ended up in the same issue.

How could I debug this error?. Anyone has an idea of what could be 

Thanks !
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20160420/de574a4c/attachment-0001.html 

More information about the Bro mailing list