[Bro] broctl unable to find peers

Zeolla@GMail.com zeolla at gmail.com
Wed Dec 21 09:18:17 PST 2016

I'm seeing an issue using bro 2.4.1 where when I run `./broctl status` it
hangs on 'Getting peer status ...'.  When I run the same command specifying
manager, any of the proxies, or any of the individual workers it has no
issue.  Has anybody seen this before?

This is a 5 node cluster (1 manager, 4 sensors) running on Ubuntu 14.04.  I
am in the process of upgrading to 2.5, but before I do so I'm adding 2
additional sensor machines (bringing it to 7 nodes) to the cluster because
we sorely need the additional processing power.  After the upgrade to 2.5 I
will be adding another node and splitting the logger function onto it,
making it an 8 node cluster.

Here's an example of me running `./broctl status` and it failing after 3
1/2 minutes, then it goes on to successfully get the status for every
component/instance specifically, however the Peers section returns "???".

$ time ./broctl status || time ./broctl status manager;time for proxy in
{1..5}; do ./broctl status proxy-${proxy}; done;for svr in {1..4}; do for
instance in {1..20}; do ./broctl status worker-${svr}-${instance}; done;

removing stale lock

Getting process status ...

Getting peer status ...


real 3m35.233s

user 0m0.126s

sys 0m0.119s

waiting for lock (owned by PID 22222) ...

Getting process status ...

Getting peer status ...

Name         Type    Host             Status    Pid    Peers  Started

manager      manager A.B.C.D   running   11111  ???    18 Dec 03:24:38




Sent from my mobile device
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20161221/9f91abf6/attachment.html 

More information about the Bro mailing list