[Bro] broctl unable to find peers

Zeolla@GMail.com zeolla at gmail.com
Wed Dec 21 09:49:18 PST 2016

I've tested with iptables stopped and have the same issue. We do typically
run with iptables up but have openings for all the required communication
as far as I'm aware.  This additional context may be helpful:

$ ./broctl status

Getting process status ...
Getting peer status ...
$ Traceback (most recent call last):
File "<string>", line 1, in <module>
File "<string>", line 23, in <module>
File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded


On Wed, Dec 21, 2016 at 12:39 PM Azoff, Justin S <jazoff at illinois.edu>

> > On Dec 21, 2016, at 12:18 PM, Zeolla at GMail.com <zeolla at gmail.com> wrote:
> >
> > I'm seeing an issue using bro 2.4.1 where when I run `./broctl status`
> it hangs on 'Getting peer status ...'.  When I run the same command
> specifying manager, any of the proxies, or any of the individual workers it
> has no issue.  Has anybody seen this before?
> You likely have iptables enabled on your hosts and it is preventing broctl
> from connecting to bro on the workers.
> https://www.bro.org/sphinx/components/broctl/README.html#bro-communication
> --
> - Justin Azoff
> --


Sent from my mobile device
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20161221/0db29279/attachment.html 

More information about the Bro mailing list