[Bro] Problem with installing Bro Postgresql plugin

Johanna Amann johanna at icir.org
Fri Apr 7 11:17:03 PDT 2017


Looks like you need to install libpq-dev (and potentially 
postgresql-server-dev too); at the moment you probably do not have the 
header files installed. After that installation will probably even work 
without the additional flags.

Johanna

On 7 Apr 2017, at 10:59, Ul Asad, Hafiz wrote:

> Hi,
>
> I am getting the error which is attached.
>
> Asad
>
> -----Original Message-----
> From: Johanna Amann [mailto:johanna at icir.org]
> Sent: 07 April 2017 17:40
> To: Ul Asad, Hafiz <Hafiz.Ul-Asad.1 at city.ac.uk>
> Cc: bro at bro.org
> Subject: Re: [Bro] Problem with installing Bro Postgresql plugin
>
> Hi Asad,
>
> please use the version available at
> https://github.com/0xxon/bro-postgresql and try
>
> ./configure --bro-dist=[your bro source distribution] 
> --with-postresql-inc=`pg_config --includedir` 
> --with-postresql-server-inc=`pg_config --includedir-server` 
> --with-postresql-lib=`pg_config --libdir`
>
> (or just use bro-pig for the installation, which should use all this 
> by default).
>
> Johanna
>
> On 7 Apr 2017, at 3:26, Ul Asad, Hafiz wrote:
>
>> Hi,
>>
>> I have been trying to install Bro 'postgresql' plugin but have been
>> unsuccessful. The postgresql is there on my Ubuntu 14.04 OS but
>> apparently Bro can't find it's library and the include directory. Any
>> help please.
>>
>> Asad
>>
>> _______________________________________________
>> Bro mailing list
>> bro at bro-ids.org
>> http://mailman.ICSI.Berkeley.EDU/mailman/listinfo/bro


More information about the Bro mailing list