[Bro] Bro seg faults when used with gperftools monitoring.

fatema bannatwala fatema.bannatwala at gmail.com
Wed Feb 15 13:37:18 PST 2017


So, I wanted to find out whether there are any memory leaks in any of the
code/scripts,
that I am loading with Bro, therefore I installed gperftools and compiled
Bro 2.5 on a VM
with 5GB of memory and centos 7.2.

I loaded only the default scripts to start with, i.e didn't include any
custom scripts in local.bro.
I ran Bro as default on a pcap (~11G) and it terminated normally producing
output log files.

When I ran Bro with Perftools heap leak checker active on the same pcap, it
seg faulted
after some time.
I was watching memory usage during the run and it didn't seem to be using
100% of available
memory.

Hence wanted to ask Is there any reason Bro would seg fault while run with
HEAPCHECK enabled?

My goal was to load custom scripts one by one and everytime run bro with
heap check
to see what can cause a memory leak. But stumbled upon this at the very
beginning,
so until I find out why it seg faulted on default configs, I can't really
check the custom scripts/code
for memory leak :( :(

Including the coredump file.

Thanks,
Fatema.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20170215/4fc0b1f6/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dump
Type: application/octet-stream
Size: 32024 bytes
Desc: not available
Url : http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20170215/4fc0b1f6/attachment-0001.obj 


More information about the Bro mailing list