[Bro] `bro-pkg install .` issue

Zeolla@GMail.com zeolla at gmail.com
Wed Sep 13 12:53:43 PDT 2017

Problem solved - user error, but with some follow-up.

At first, I thought bro-pkg install . was leveraging the local (./)
directory structure, but instead it was using the local git repo, and
assumed the master branch (not the current branch).  If I run bro-pkg
install . --version bro-pkg (which is the name of my git branch with the
right bro-pkg.meta file) it works just fine.

Per a chat with Jon, I've opened this issue
<https://github.com/bro/package-manager/issues/12> as a follow-on.


On Wed, Sep 13, 2017 at 1:03 PM Azoff, Justin S <jazoff at illinois.edu> wrote:

> > On Sep 13, 2017, at 12:12 PM, Siwek, Jon <jsiwek at illinois.edu> wrote:
> >
> >
> >> On Sep 13, 2017, at 9:45 AM, Zeolla at GMail.com <zeolla at gmail.com> wrote:
> >>
> >> Under step 6 of this documentation it shows that you can install a
> package with `bro-pkg install .`, but I'm having some issues doing that.
> I've attached a screenshot - anybody know why this would be happening?
> >
> > At a glance, I don’t know what would cause that.  You could try going
> through the full steps of the walkthrough you linked with a dummy package
> just to see if it works with a simpler package.  If it doesn’t work with a
> simpler dummy package, that’s clearly a bug.  Or generally feel free to
> open a github issue for this.
> I think I ran into the same issue when the local git repo was in a weird
> state.. like I hadn't committed yet, or hadn't created a tag yet.. so the
> git stuff that bro-pkg does got confused.  Problem went away on its own
> once I had things more fleshed out.
> --
> - Justin Azoff
> --

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ICSI.Berkeley.EDU/pipermail/bro/attachments/20170913/7f94305e/attachment.html 

More information about the Bro mailing list