[ee122] Can't find my traffic using wireshark

Richard Schmidt huntingtonsurfca at gmail.com
Tue Oct 30 01:06:26 PDT 2007

Ok so for everyone who will inevitably want to do know:

You have to recompile your server on ilinux3. But ilinux3 doesn't
recognize -lsocket so your usual makefile won't work. However, you can
just compile using

>gcc -c yourfile.c


> gcc yourfile.o -o http_server [No need to link -lsocket or -lnsl...]

And the server will run fine (go figure...).

Also cool, when running your server on ilinux3 you can (if you've done
the project correctly) access your webServer from a normal web

Just click on the link you've typed into the client and a browser
should pop up displaying the same stuff. It'll take the same arguments
you provide into the address bar as the http_client, and will display
text, etc.


On 10/29/07, vern at cs.berkeley.edu <vern at cs.berkeley.edu> wrote:
> > star [61] ~/proj1b > /share/b/ee122/tcpdump -s 0 -i lo0 -w file.trace
> > tcpdump.sun4u: lo0: No DLPI device found
> >
> > ----------
> > I tried this with other numbers and still the same error.
> Hmmmm, I don't know how to get this to work on Solaris :-(.
> Can you run the client and server on separate machines?  I believe
> ilinux3.eecs didn't firewall off user servers from the net.
>                Vern

More information about the ee122 mailing list