[ee122] ilunx3 doesn't like us.

Lisa Fowler fowler at eecs.berkeley.edu
Fri Sep 21 21:34:36 PDT 2007


I think you misunderstood what ilinux3.eecs.berkeley.edu was for.

You should ssh into ilinux3 with your inst account and test *your*
server there.  You should likely want to use a different port number
so that you won't collide with other students (e.g. the last 5 digits
of your Cal ID number).  You might have to recompile your server for
running on ilinux3.

I just sshed in with my account and ran my own server:
ilinux3 [11] ~/trunk > ./echo_server 9405

Starting EchoServer on TCP Port 9405 and UDP Port 9405...
70.143.85.198:52473 Received new connection
70.143.85.198:52473: Received over TCP: alsdkjf
70.143.85.198:52473: Closed connection (socket 5).

You are correct that 7788 is closed right now, but it's for you to run
something.  Telnetting to port 7788 isn't going to do anything for
you.  There's no telnet server listening on that port....

-Lisa

On 9/21/07, Richard Schmidt <huntingtonsurfca at gmail.com> wrote:
> I was wondering, "Why oh why is my program not working? I'm doing everything
> right!"
>
> I even loaded the partA client and tried to connect to
> ilinu3.eecs.berkeley.edu and suddenly couldn't connect even though it worked
> before...
>
> Then I tried telnet-ing into ilinux3
>
> sphere [63] ~/proj1a > telnet ilinux3.eecs.berkeley.edu 7788
> Trying 128.32.48.222...
> telnet: Unable to connect to remote host: Connection refused
>
> >:(
>
> Luckily jaguar.icir.org:7 is still letting me in.
>
> On the bright side, this connection problem did make me pour over my parsing
> code and I found numerous bugs (mainly a problem with DeMorgan's and
> characters).
>
> But fyi to all you other intrepid coders.
> Rick
> _______________________________________________
> ee122 mailing list
> ee122 at mailman.ICSI.Berkeley.EDU
> http://mailman.ICSI.Berkeley.EDU/mailman/listinfo/ee122
>
>


More information about the ee122 mailing list