[Netalyzr] upstream buffering test

Brian J. Murrell brian at interlinx.bc.ca
Sun Feb 26 21:25:59 PST 2012


I have tried running your netalyzer on my network here and I want to
verify the upstream buffering results.

I run QoS here on my network and see quite stable ping times while I
saturate my upstream bandwidth.  During such a test I am doing:

$ scp a_big_file $host

and while doing that I run "mtr $host" to watch the jitter of each hop
along the path.

$host is 9 hops away and usually about 25ms +-3-5ms.  While I'm scp'ing
that big file (about 17MB) the standard deviation for most hops on the
path to $host remains in the 5-10ms range which about the same whether
the upstream is saturated or not.

So my question is, how is netalyzer testing my upstream buffering such
that it's seeing a second or more of buffering when I'm not seeing it
using the above test?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
Url : http://mailman.ICSI.Berkeley.EDU/pipermail/netalyzr/attachments/20120227/a1313dec/attachment.bin 

More information about the Netalyzr mailing list