[Netalyzr] how to run single test in the CLI version

Mikael Abrahamsson swmike at swm.pp.se
Fri Feb 9 11:27:12 PST 2018


On Fri, 9 Feb 2018, Christian Kreibich wrote:

> Unfortunately that's not what the mode flag does -- this flag is 
> primarily for labeling a session as it enters our database, to allow us 
> to identify sets of sessions that are coming in from a certain 
> experiment, setting, partner site, etc. It may also mean a slightly 
> tweaked set of tests, but there's currently no way to run a single test. 
> If you send us some of your session IDs (feel free to keep these 
> off-list), we'd be happy to take a look regarding what might be going 
> wrong.

Thanks for the response. I already have packet dumps of the test, so I can 
tell what the last packet is that is sent right before the device crashes 
(and I also know that it has to do with the packet forwarding acceleration 
code on the device, because when I unload all acceleration then things 
work as expected without any crash).

I know the device crash occurs around test 58/110, but I am not 100% sure 
exactly which of these tests that cause it, because it could also be that 
the crash (and it's a kernel crash+reboot) is caused by a delayed reaction 
to an earlier test.

So it would be really helpful if the CLI client would support to just run 
one of the tests, and perhaps not even create a report. Another option 
would be to be able to insert a 5 second delay between each test, to 
easily isolate them.

So if you're going to re-open the cli client for development, please take 
what I wrote above under advisement.

Thanks!

-- 
Mikael Abrahamsson    email: swmike at swm.pp.se


More information about the Netalyzr mailing list