[Xorp-hackers] Query regarding XRL's

Pavlin Radoslavov pavlin at icir.org
Fri Feb 16 15:53:50 PST 2007


> > Did you run ./bootstrap from the top-level XORP directory?
> > This will generate Makefile.in from the Makefile.am files.
> > Then running ./configure will generate the final Makefile from
> > Makefile.in.
>      When i make new .tp file then after using ./bootstrap, thn ./configure,
> gamke , it works.
> but when i tried ./bootstrap (i modified existing .tp file didnt made new
> one), tried gmake it worked but when i used ./bootsrap gave me error (in
> short ./bootstrap spoiled my scource code coz now gmake fails event after
> making gmake clean/distclean) !!

If you just modified an existing *.tp file there is no need to run
./bootstrap. Typically you need to run ./bootstap only if you modify
a Makefile.am or configure.in file.

>          So is there any way to revert action done by ./bootstrap ?? :)

Not trivially.

If you are using XORP CVS code (from anon CVS), then
"cvs update -d -P" and "cvs diff -u -p" will tell you which are the
modified files so you can reverse only those files.
E.g., if you delete a corrupted file then "cvs update -d -P" will
bring it back from anon CVS.

If you are using a release like xorp-1.3, then you need to run
something like "diff -ur xorp.org xorp.new" to see the differences
between the original and your code (where xorp.org and xorp.new are
the directories with the original XORP code and your version).

> My installed libtool version is :
> 
>   (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
> 
> According to Readme required is - libtool version 1.3.4
> 
> ********************************************************************************
> Error Shown :
> 
> linux-m4ij:/home/xorp/Desktop/project/bidir-enable/xorp-1.3 # gmake
> gmake  all-recursive
> gmake[1]: Entering directory `/home/xorp/Desktop/project/bidir-enable/xorp-
> 1.3'
> Making all in libxorp
> gmake[2]: Entering directory `/home/xorp/Desktop/project/bidir-enable/xorp-
> 1.3/libxorp'
> gmake  all-am
> gmake[3]: Entering directory `/home/xorp/Desktop/project/bidir-enable/xorp-
> 1.3/libxorp'
> if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.
> -I.. -I..    -g -W -Wall -Wwrite-strings -Wbad-function-cast
> -Wmissing-prototypes -Wcast-qual -Wmissing-declarations -Werror
> -Wpointer-arith -Wcast-align -Wstrict-prototypes -Wnested-externs -pipe -MT
> debug.lo -MD -MP -MF ".deps/debug.Tpo" -c -o debug.lo debug.c; \
> then mv -f ".deps/debug.Tpo" ".deps/debug.Plo"; else rm -f
> ".deps/debug.Tpo"; exit 1; fi
> libtool: unrecognized option `--tag=CC'
> Try `libtool --help' for more information.
> gmake[3]: *** [debug.lo] Error 1
> gmake[3]: Leaving directory `/home/xorp/Desktop/project/bidir-enable/xorp-
> 1.3/libxorp'
> gmake[2]: *** [all] Error 2
> gmake[2]: Leaving directory `/home/xorp/Desktop/project/bidir-enable/xorp-
> 1.3/libxorp'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory `/home/xorp/Desktop/project/bidir-enable/xorp-
> 1.3'
> gmake: *** [all] Error 2
> *******************************************************************************

Did you read the rest of my email, and more specifically the last
sentence in the following paragraph? :)

> > Note that you must have installed the autoconf/automake/libtool
> > tools for ./bootstrap to work.
> > Also, see README for the versions of the tools we are using. It is
> > best to install exactly same versions, otherwise there is no
> > guarantee that it will work.

We are planning to update the autoconf/automake/libtool versions to
something more recent, but in the mean time your best bet is to
use the versions that are listed in README (or at least versions
that are as close as possible to our versions).

Regards,
Pavlin



More information about the Xorp-hackers mailing list