[Xorp-hackers] Another problem compiling xorp 1.6 and ubunto 9.10

Ben Greear greearb at candelatech.com
Thu Jun 17 17:30:02 PDT 2010

On 06/17/2010 04:32 PM, kfriedman at syncadence.com wrote:
> Hello,
> I'm trying to get xorp version 1.6 to compile under ubunto 9.10, gcc and
> g++ versions 4.4.1. Like others I had problems with "#ident" but was
> able to work around that by including "-Wno-deprecated" in the configure
> and rebuilding the make files.
> /bin/bash ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I.
> -I.. -I.. -g -Werror -W -Wall -Wno-deprecated -Wwrite-strings
> -Wcast-qual -Wpointer-arith -Wcast-align -Woverloaded-virtual
> -ftemplate-depth-25 -pipe -MT vif.lo -MD -MP -MF .deps/vif.Tpo -c -o
> vif.lo vif.cc
> g++ -DHAVE_CONFIG_H -I. -I.. -I.. -g -Werror -W -Wall -Wno-deprecated
> -Wwrite-strings -Wcast-qual -Wpointer-arith -Wcast-align
> -Woverloaded-virtual -ftemplate-depth-25 -pipe -MT vif.lo -MD -MP -MF
> .deps/vif.Tpo -c vif.cc -o vif.o
> In file included from vif.hh:32,
> from vif.cc:29:
> ipvxnet.hh: In member function 'void
> IPNet<A>::initialize_from_string(const char*) [with A = IPvX]':
> ipvxnet.hh:57: error: invalid conversion from 'const char*' to 'char*'
> I think the problem may be due to an overloaded strrchr() function.

xorp.ct should compile  & work fine, and if it doesn't, I'll fix it:


There is no active development on 1.6 release (that I'm aware of).


> Any ideas?
> Thanks,
> Kirk
> _______________________________________________
> Xorp-hackers mailing list
> Xorp-hackers at icir.org
> http://mailman.ICSI.Berkeley.EDU/mailman/listinfo/xorp-hackers

Ben Greear <greearb at candelatech.com>
Candela Technologies Inc  http://www.candelatech.com

More information about the Xorp-hackers mailing list