[Xorp-users] cost of passive ospf interfaces is zero?

Eric S. Johnson esj at cs.fiu.edu
Mon Dec 7 14:55:22 PST 2009


This may be me just misunderstanding something, but...

With zebra and cisco routers if you have an interface set to 
"passive" but the network configured in the router ospf stanza, 
the network gets advertised (stub) with the cost as specified in the
"ip ospf cost XXX" in the interface stanza.


With xorp, if I set the network as passive the network is advertised
with a cost of 0.

IE: (forgive the ascii art :)

another router (eth0=10.11.1.2) <- net 10.11.1.0/24 -> (10.11.1.1=eth0) problem router (eth1=10.11.0.1) <- net 10.11.0.0/24 ->

If "problem router is a quagga (or IOS router, assume correct syntax difference)
and is configured:

interface eth0
 ip address 10.11.1.1/24
 ip ospf cost 5000

interface eth1 
 ip address 10.11.0.1/24 
 ip ospf cost 5000

router ospf 
 network 10.11.1.0/24 area 1
 network 10.11.0.0/24 area 1
 passive-interface eth1


Then "another router" sees the cost to 10.11.0.0/24 as 5000 plus the cost
out "another router"'s eth0.

But if "problem router" is xorp with the ospf4 stanza looking like this:

protocols {
    ospf4 {
	    router-id: 10.11.0.1
	    area 0.0.0.1 {
		interface eth0 {
		    vif "eth0" {
			address 10.11.1.1 {
			    priority: 0
			    interface-cost: 5000
			}
		    }
		}
		interface eth1 {
		    vif "eth1" {
			address 10.11.0.1 {
			    priority: 0
			    interface-cost: 5000
			    passive {
				disable: false
				host: false
			    }
			}
		    }
		}
	}
}


Then "another router" sees the cost to 10.11.0.0/24 as ONLY the cost
out "another router"'s eth0. The cost of the stub network is advertised
by "problem router" as 0. 

I verified this with tcpdump. If the interface is set to passive 
the LSA sent sets the cost to 0.

Now, granted, if network 10.11.0.0/24 is *REALLY* a stub network 
the cost to it shouldn't matter, but in my environment, it is not 
really a stub area, I just don't want OSPF to build adjacenies on it.

And the behavior is different then other implementations....

Is this a bug? A feature? A sign for me to stop mis-using the concept
of stub networks?

Thoughts?

E



More information about the Xorp-users mailing list