[Xorp-users] Help : Test setup for Pim4 and IGMP between sunets (for VLC source and Receiver ) multicast test.

RIKKERS Jorn jorn.rikkers at nl.thalesgroup.com
Tue Mar 2 01:20:31 PST 2010


I'm currently doing some tests with the folowing layout
 
R-----R---{Internet}
| \ / |
R--R--R
| / \ |
R-----R

Every Router (R) has another interface to a PC (this is not shown in the figure).

I use the folowing configuration for XORP and Quagga in the routers (see below). All routers have similar config files.

Note that for every network segment one PIM DR has a higher priority.
Note that IGMP has to be configured only for the interface to which a PC is connected. This is not the case for PIM.

I hope this will help you a litle…

Jorn Rikkers

*This message contains Unclassified information*

/* ------------------ XORP config file ------------------ */
interfaces {
	interface eth3 {
		vif eth3 {
			address 10.0.0.37 {
				prefix-length: 30
			}
		}
	}
	interface eth2 {
		vif eth2 {
			address 10.0.0.34 {
				prefix-length: 30
			}
		}
	}
	interface eth1 {
		vif eth1 {
			address 10.0.0.30 {
				prefix-length: 30
			}
		}
	}
	interface eth0 {
		vif eth0 {
			address 10.0.0.5 {
				prefix-length: 30
			}
		}
	}
}
fea {
	unicast-forwarding4 {
		disabl: false
	}
}
plumbing {
	mfea4 {
		disable: false
		interface eth3 {
			vif eth3 {
				disable: false
			}
		}
		interface eth2 {
			vif eth2 {
				disable: false
			}
		}
		interface eth1 {
			vif eth1 {
				disable: false
			}
		}
		interface eth0 {
			vif eth0 {
				disable: false
			}
		}
		interface register_vif {
			vif register_vif {
				disable: false
			}
		}
	}
}
protocols {
	fib2mrib {
		disable: false
	}
}
protocols {
	igmp {
		interface eth0 {
			vif eth0 {
				disable: false
			}
		}
	}
}
protocols {
	pimsm4 {
		interface eth3 {
			vif eth3 {
				dr-priority: 1
			}
		}
		interface eth2 {
			vif eth2 {
				dr-priority: 2
			}
		}
		interface eth1 {
			vif eth1 {
				dr-priority: 2
			}
		}
		interface eth0 {
			vif eth0 {
				dr-priority: 1
			}
		}
		interface register_vif {
			vif register_vif {
				disable: false
			}
		}
		static-rps {
			rp 10.0.0.17 {
				group-prefix 224.0.0.0/4 {
				}
			}
		}
	}
}
/* ----------------------end XORP ---------------------- */

/* ----------------- QUAGGA config file ----------------- */
hostname router2
!
interface eth3
 ip address 10.0.0.37/30
!
interface eth2
 ip address 10.0.0.34/30
!
interface eth1
 ip address 10.0.0.30/30
!
interface eth0
 ip address 10.0.0.5/30
!
router ospf
 redistribute connected
 router -id 10.0.0.5
 network 10.0.0.37/30 area 0
 network 10.0.0.34/30 area 0
 network 10.0.0.30/30 area 0
 network 10.0.0.5/30 area 0
!
/* ---------------------end QUAGGA --------------------- */




From: xorp-users-bounces at xorp.org [mailto:xorp-users-bounces at xorp.org] On Behalf Of saurabh
Sent: Friday, 26 February, 2010 12:58
To: xorp-users at xorp.org
Subject: [Xorp-users] Help : Test setup for Pim4 and IGMP between sunets (for VLC source and Receiver ) multicast test.


Dear Xorp users,

"I think many of other xorp users must passed this stage, at where I am struggling right now" 
I am struggling to make the test setup of pim and igmp (after going thru manuals and rfcs)

Aim is to see multicast traffic in VLC player at PC1 which is coming from PC2 (multicast source for 224.0.0.4)
,Off course through PIM and IGMP. (I should see proper join & prune at both routers) 

I have two pc(win-xp),  (At diff subnets)
      two routers (both run Xorp live cd). 

With 2nd XP pc2, I am multicasting stream at 224.0.0.4 group..udp(port 1234).. 
And @ 1st xp pc1, I am trying to view the video stream. 

Both Pcs are behind different xorp (live cd) router as shown in figure below..

PC1 –xp                                      PC2 -xp
193.193.193.111                       194.194.194.111        
     eth(0)                                          (eth0)
            |                                             |     
            |                                             |    
    le1 193.193.193.1        le1 194.194.194.1    (pim-RP) (DR)
    le0 195.195.195.20     le0 195.195.195.10              
  XORP-CD-Router1 ----  XORP-CD-Router2


(bsd naming are le0..1 ..instead of eth0.1..)

IGMP activity is happening: (☺)
What I observed is that PC1's vlc client is joining 224.0.0.4 group, when I start to
Play button of vlc,  I can see it by "show igmp group" command at router1's cli, 
 
No PIM activity is happening: (☹)
I noted that router1 is not sending pim join (*,G) to router2 for group 224.0.0.4 
(Which should be as I have defined router1's le0 as RP for group 224.0.0.4/8)

Only I can see pim neighbors while trying command ("show pim neighbors"), in both
routers , in that case router1 is being shown as NOT DR, and router2 as DR

And I have also noted that multicast traffic that is coming at le1 in router2, 
(from PC2-which is multicast source)  that is not forwarded to le0. 
(I think which should be, as it must go to RP interface which is le0 of router2) ! 

Plese help me, what I missing something? 

I have configured fib2mrib.. And not configured any other unicast protocols.  (Is this correct)
I have also not set default gateway (default routes in any routers)


I think "Mohd" and other users have done this setup that I saw from sep-oct-2009 mailing list? 

Plese share your exp. for pim igmp setup.. 


config are below,,,,


Thanks,
Saurabh

config file for router2 i given here in last, in router1 config only change 
in interface address, remaining all are same

****************************************************

root at xorpcd.local# show 

    protocols {
        fib2mrib {
        }
        igmp {
            interface le0 {
                vif le0 {
                }
            }
            interface le1 {
                vif le1 {
                }
            }
        }
        pimsm4 {
            interface le0 {
                vif le0 {
                    dr-priority: 250
                }
            }
            interface le1 {
                vif le1 {
                }
            }
            interface "register_vif" {
                vif "register_vif" {
                }
            }
            static-rps {
                rp 195.195.195.10 {
                    group-prefix 224.0.0.0/8 {
                        rp-priority: 250
                    }
                }
            }
            switch-to-spt-threshold {
                interval: 10
                bytes: 1000000
            }
        }
    }
    fea {
        unicast-forwarding4 {
        }
    }
    interfaces {
        interface le0 {
            description: "Ethernet"
            vif le0 {
                address 195.195.195.10 {
                    prefix-length: 24
                }
            }
        }
        interface le1 {
            description: "Ethernet"
            vif le1 {
                address 194.194.194.1 {
                    prefix-length: 24
                }
            }
        }
        interface lo0 {
            description: "Loopback interface"
            vif lo0 {
            }
        }
    }
    plumbing {
        mfea4 {
            interface le0 {
                vif le0 {
                }
            }
            interface le1 {
                vif le1 {
                }
            }
            interface "register_vif" {
                vif "register_vif" {
                }
            }
        }
    }




More information about the Xorp-users mailing list