[Bro-Dev] Difference between port conversion functions

Robin Sommer robin at icir.org
Thu Nov 17 07:43:47 PST 2011

On Wed, Nov 16, 2011 at 22:47 -0800, you wrote:

>     function count_to_port%(c: count, t: transport_proto%): port
>     function to_port%(num: count, proto: transport_proto%): port

Yeah, looks like one can go. We should keep the one which's naming is
more consistent with other coverters; which I believe should be
count_to_port because the first argument is a specific type (and not
"any" as other to_* function use). This is out of my memory though,
worth checking.


Robin Sommer * Phone +1 (510) 722-6541 * robin at icir.org
ICSI/LBNL    * Fax   +1 (510) 666-2956 *   www.icir.org

More information about the bro-dev mailing list