[Bro-Dev] [JIRA] (BIT-1099) ./build/bro-git-20131129/lib/broctl/plugins/lb_myricom.py

grigorescu (JIRA) jira at bro-tracker.atlassian.net
Mon Dec 2 16:58:45 PST 2013

    [ https://bro-tracker.atlassian.net/browse/BIT-1099?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14900#comment-14900 ] 

grigorescu commented on BIT-1099:

Hi Tyler,

First off - is this actually causing a problem for you? 

It's set this way to work with both SNF1 and SNF2. You're looking at SNF2, which doesn't define 0x100. SNF1 does:

# If incoming data is to be partitioned across rings via RSS, an
# alternative receive mode is to set the SNF_F_RX_PRIVATE=0x100 flag
# which reduces the amount of shared SNF references at the cost of
# an additional copy. This approach may provide better capture behavior
# when the RSS distribution is unbalanced or more generally, when the
# consumption rate of each process varies enough to cause large amounts
# of packet drops. Here we set the SNF_F_RX_PRIVATE=0x100 flag with
# SNF_F_PSHARED=0x1 flag to allow process-sharing.
# export SNF_FLAGS=0x101

Setting this to 0x101 shouldn't affect SNF2 drivers; it will be like 0x1 to them.

> ./build/bro-git-20131129/lib/broctl/plugins/lb_myricom.py
> ---------------------------------------------------------
>                 Key: BIT-1099
>                 URL: https://bro-tracker.atlassian.net/browse/BIT-1099
>             Project: Bro Issue Tracker
>          Issue Type: Problem
>          Components: BroControl
>    Affects Versions: git/master
>         Environment: RHEL6
> Myricom 10G
>            Reporter: tyler.schoenke
>              Labels: Myricom, RHEL6
> Hi All,
> First, unrelated, thanks for fixing whatever was wrong with PktSrc.cc:222.  I was core dumping on that with the Myricom 10G until I upgraded to the latest git version of Bro.
> I had been running with my Myricom environment variables configured in .bash_profile, but decided to move them to etc/node.cfg because that feature is now available in Bro 2.2.  
> When I tried to start the workers, they failed and I got the message to run diag.  When I ran diag, I noticed it showed the following.  
> 28366 snf.0.-1 P (environ)        SNF_DATARING_SIZE = 2147483648 (0x80000000) (2048.0 MiB)
> 28366 snf.0.-1 P (default)        SNF_DESCRING_SIZE = 536870912 (0x20000000) (512.0 MiB)
> 28366 snf.0.-1 P (userset)                SNF_FLAGS = 257 (0x101)
> 28366 snf.0.-1 P (environ)           SNF_DEBUG_MASK = 3 (0x3)
> 28366 snf.0.-1 P (default)       SNF_DEBUG_FILENAME = stderr
> Everything looks great except for SNF_FLAGS.  Myricom defaults it to 0x1, and that was working when I ran bro from the command line.
> I found it was getting set in ./build/bro-git-20131129/lib/broctl/plugins/lb_myricom.py
> According to /opt/snf/include/snf.h, the only  valid values for SNF_FLAGS are 0x1, 0x2, and 0x300.  No possible combination of those will add up to 0x101.   I'm guessing that is a typo.  If not, please explain why it is defaulted to that, otherwise you may want to default to 0x1.  
> Thanks,
> Tyler

This message was sent by Atlassian JIRA

More information about the bro-dev mailing list