[Bro-Dev] [JIRA] (BIT-1270) topic/gilbert/plugin-api-tweak
jira at bro-tracker.atlassian.net
Fri Oct 10 19:57:07 PDT 2014
[ https://bro-tracker.atlassian.net/browse/BIT-1270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18301#comment-18301 ]
gclark commented on BIT-1270:
* Only bad thing about a tuple is that the members would no longer be named, which can make accesses more difficult to read in the code. Assuming I'm understanding this suggestion properly, what about modifying this to pass / return the existing ValWrapper by value instead? This way, the members would retain readable names, but it would still eliminate some complexity.
* Re: internalerror - good to know, thanks
* Re: coding conventions - sorry about that: will get things cleaned up.
> Key: BIT-1270
> URL: https://bro-tracker.atlassian.net/browse/BIT-1270
> Project: Bro Issue Tracker
> Issue Type: Improvement
> Components: Bro
> Reporter: gclark
> Assignee: gclark
> This branch makes a few changes to the API:
> * Wraps values in a simple class (ValWrapper) that include an explicit processed / not processed flag (to avoid confusion with delayed / opaque invocations).
> * Adds a Frame argument to HookCallFunction
> * Adds support for Frame argument types to HookArgument
> * Adds support for ValWrapper argument types to HookArgument
> * Tweaks the plugin.hooks tests a bit to include new output (from additional argument)
> * Tweaks the plugin.api-version-mismatch to remove explicit home directory path via simple regex
This message was sent by Atlassian JIRA
More information about the bro-dev