[Bro-Dev] [JIRA] (BIT-1270) topic/gilbert/plugin-api-tweak
jsiwek at illinois.edu
Mon Oct 20 12:53:34 PDT 2014
> On Oct 20, 2014, at 10:05 AM, Robin Sommer <robin at icir.org> wrote:
> So one thing to keep in mind is that not many people will ever write
> code using this; it's just for function hooks, and I imagine their use
> will be limited. I'm personaly still leaning towards the pair, but
> it's not a big deal, the main point was the pass-by-value, and I'm
> fine either way.
Me too (I was just in a “let me help brainstorm pros/cons” mood that day).
> If we stick with the wrapper, we should however at
> least rename to something more semantically meaninful than ValWrapper,
> like ValOrNull (better ideas appreciated :).
Not having to choose a name I guess is a “pro” for std::pair :)
More information about the bro-dev