[Bro-Dev] switch to requiring CMake 2.8+ for Bro 2.4 ?

Daniel Thayer dnthayer at illinois.edu
Tue Jan 6 16:37:42 PST 2015

On 01/06/2015 04:15 PM, Siwek, Jon wrote:
> Doing a quick survey of what the major platforms offer, I found
> EL 6.6: CMake 2.8.12
> Ubuntu 14.04 LTS: CMake 2.8.7
> Debian 7.0: CMake 2.8.9
> FreeBSD 9.3: CMake 2.8.12
> Bumping up to requiring 2.8 would allow use of generator expressions.  I’d be able to use that to properly fix the CMake policy warnings in bro-aux about using the LOCATION target property.
> Bumping up to 2.8.8 would allow use of OBJECT libraries.  That would be a nice-to-have that I think would simplify CMake logic regarding how shared and static versions of libraries get built (e.g. would simplify broccoli, broker, and plugin support).
> Not aware of anything in versions beyond 2.8.8 that make them compelling enough to consider.
> It seems reasonable to now require 2.8.0, so I want to at least do that.  And if Ubuntu 14.04 gets 2.8.8 before the next Bro release, I say switch to requiring 2.8.8.  Other thoughts/opinions?
> - Jon

Something looks wrong to me (debian 7 is older than ubuntu 14.04, but
has a newer version of cmake?).  Might want to double-check what's
included with ubuntu 14.04 (I have debian 7, and it does indeed
have cmake 2.8.9).

More information about the bro-dev mailing list