[Bro-Dev] switch to requiring CMake 2.8+ for Bro 2.4 ?
jsiwek at illinois.edu
Wed Jan 7 07:54:57 PST 2015
> On Jan 7, 2015, at 8:00 AM, Damian Gerow <damian.gerow at shopify.com> wrote:
> Something looks wrong to me (debian 7 is older than ubuntu 14.04, but
> has a newer version of cmake?). Might want to double-check what's
> included with ubuntu 14.04 (I have debian 7, and it does indeed
> have cmake 2.8.9).
> I have an Ubuntu 14.04.1 system, and it's got 2.8.12 installed (for Bro). It's Ubuntu 12.04 systems that have 2.8.7 available.
Thanks, that's right: I was actually looking at 12.04 LTS, but mistakenly wrote 14.04. Support for 12.04 is supposed to go through April 2017, so my suggestions don’t change — switching to require 2.8 is “safe”, but 2.8.8 may be premature.
More information about the bro-dev