[Bro-Dev] [JIRA] (BIT-1509) Library search problem with make-rpm-packages

Daniel Thayer (JIRA) jira at bro-tracker.atlassian.net
Wed Apr 13 14:27:00 PDT 2016

    [ https://bro-tracker.atlassian.net/browse/BIT-1509?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=25706#comment-25706 ] 

Daniel Thayer commented on BIT-1509:

I tried building the rpm for Bro 2.4.1, and here's
where broccoli gets installed:


This matches the results I get when I just
build and install Bro with ./configure, make,
and make install (replacing /opt/bro with
whatever PREFIX is used).

> Library search problem with make-rpm-packages
> ---------------------------------------------
>                 Key: BIT-1509
>                 URL: https://bro-tracker.atlassian.net/browse/BIT-1509
>             Project: Bro Issue Tracker
>          Issue Type: Problem
>          Components: BroControl
>            Reporter: Robin Sommer
>             Fix For: 2.5
> The "full Bro" RPM that make-rpm-packages builds, puts broccoli.so into /opt/bro/lib, but doesn't make sure that BroControl can actually find it there, letting the "import broccoli" fail. It sounds like this used to work in 2.3, but not anymore in 2.4.
> I don't know if we want to support the RPM script going forward, given that we've switched to the SuSE build service. But as long as we keep shipping it, it would be nice if it "just worked".

This message was sent by Atlassian JIRA

More information about the bro-dev mailing list