[Bro-Dev] Broker C++ namespace: broker -> bro?
vallentin at icir.org
Thu May 12 12:42:07 PDT 2016
> Not sure I like that. The library is called Broker, so "broker" seems
> the natural namespace to me.
All right, let's keep it as is. This is also aligns with the sentiment
at our Gitter room.
> I think the better solution would be finding a different name for
> those things now called "broker" [..]
Speaking of which: let me summarize the issue. We need a good name for
something that is a message broker, an entity that communicates in the
publish/subscribe paradigm. These message brokers can communicate via
TCP or shared memory, and any program can have a large number of them.
In the current Broker code, we use the term "endpoint," but I find it
implies too little pub/sub. I'm currently using the term "broker"
instead. However, this is also the library name and could cause some
confusion. Internally, a "broker" maps to an actor (as in the actor
model). If anyone has suggestions on how to better name these abstract
pub/sub entities, please chime in.
More information about the bro-dev