[Bro-Dev] Broker C++ namespace: broker -> bro?
jsiwek at illinois.edu
Fri May 13 09:30:29 PDT 2016
> On May 12, 2016, at 2:42 PM, Matthias Vallentin <vallentin at icir.org> wrote:
> In the current Broker code, we use the term "endpoint," but I find it
> implies too little pub/sub. I'm currently using the term "broker"
> instead. However, this is also the library name and could cause some
> confusion. Internally, a "broker" maps to an actor (as in the actor
> model). If anyone has suggestions on how to better name these abstract
> pub/sub entities, please chime in.
To me a “broker” in a pub/sub system describes a thing that sits between publisher and subscribers (distinct from either) and manages the flow/filtering of messages. The internals of the library itself, already named Broker, do seem to serve that role, and so naming another thing “broker” adds confusion.
Ideas fort improving the name of “endpoint”:
(1) Make up a name that looks/sounds like pub/sub. e.g. call it a “pubsub” or a “pubsubber”
(2) Try to decouple the publisher and subscriber features into two separate classes and just literally name them “publisher” and “subscriber”.
More information about the bro-dev