[ee122] Issues with c199

Anthony Kilman a_kilman at berkeley.edu
Tue Oct 30 15:34:04 PDT 2007

Hello.. I have my project ready to go. I finished the labs and
everything. I did most of the testing on ilinux3.eecs.berkeley.edu and
on my box at home.

Thought I'd give it a run on c199.eecs.berkeley.edu, but it was a no go.
I used the same make file in the reference code, and did a clean make.
It compiles, starts running, but just sits there. I got on gdb to see
the exact call that it hangs on.. select.

I've tried several combinations of client/server types. My box at home,
to ilinux3, that worked fine. Other way around.. works fine. Using
myhostname.local client/server both running on my machine, fine.. c199
is just being really stubborn.

And, on top of that, I thought I'd try the other way around. Run the
server on ilinux, and the client on c199. Just be thorough. Using the
same make file as the reference code, it doesn't get past the linking
stage. Here's what I get:

c199 [67] ~/proj1b/client > make
g++ -ggdb -Wall-lsocket -lnsl -o http_client http_client.cpp
Undefined                       first referenced
 symbol                             in file
recv                                /var/tmp//cctgg1cH.o
send                                /var/tmp//cctgg1cH.o
__xnet_connect                      /var/tmp//cctgg1cH.o
__xnet_socket                       /var/tmp//cctgg1cH.o
ld: fatal: Symbol referencing errors. No output written to http_client
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `http_client'

I should have all the correct headers, as how they are the same ones in
the ref code as well.

So, yeah. Any ideas? Also, why is c199 such a pain in the arse?



More information about the ee122 mailing list