[Bro-Dev] cmake/install question

Robin Sommer robin at icir.org
Thu Jan 27 11:46:41 PST 2011

On Thu, Jan 27, 2011 at 13:03 -0600, you wrote:

> Did something happen between the `make` as user robin and the `make install` as user bro?

No, nothing, but I've figured it out: NFS was involved, the build
was on a different machine than the install. Guess I just need to
remember to not do that. Now doing all on the same machine. 

But, sorry!, it still doesn't work. I reverted to a clean master,
did a rebuild as robin, and an install as user bro. That worked. But
then I applied my original modifiction to options.py, did another
"make" as user robin in the top-level bro directory (which went
clean and didn't shown anything done); and then did the "make
install" again as user bro:

    Error copying directory from "/home/robin/bro/master/aux/broctl/BroControl" to "/home/robin/bro/master/build/aux/broctl/BroControl".
Listing BroControl ...
Can't list BroControl
-- Installing: /home/bro/bin/broctl
CMake Error at aux/broctl/cmake_install.cmake:47 (FILE):
  file INSTALL cannot find
Call Stack (most recent call first):
  cmake_install.cmake:48 (INCLUDE)


Robin Sommer * Phone +1 (510) 722-6541 * robin at icir.org
ICSI/LBNL    * Fax   +1 (510) 666-2956 *   www.icir.org

More information about the bro-dev mailing list