[Bro-Dev] Configuration framework syntax proposal

Johanna Amann johanna at corelight.com
Thu Sep 21 08:37:16 PDT 2017

On Thu, Sep 21, 2017 at 02:57:31PM +0000, Siwek, Jon wrote:
> > I'm not sure how exposing something like "input.pcap.filter" is any different from exposing something like "Pcap::filter" from that standpoint.  Maybe there's a larger discussion here around what the user experience should look like?  I feel like two different things are being talked about now.
> I’m thinking on the same lines.

Yes, I can see that argument.

> > Directly using variable names in UI elements is not unheard of though, a lot of UI frameworks will do things like present a variable like user_name as "User Name" in the UI.  This is usually a simple text transform like
> > 
> >>>> s='My_Program::user_name'
> >>>> s.replace("::", " - ").replace("_", " ").title()
> >    'My Program - User Name’
> Yeah, I’ve noticed this approach in other UIs as well.

I admittedly did not think of this - that could work as a neat default.

The only thing that I would like to avoid (which is obviously separate
from this) is internally remapping variable names to configuration names
in a non-reversible manner; then one suddenly has to think about what to
do when names conflict (several variable names being able to automatically
map to the same configuration name). But - that seem to be separate
concern :)


More information about the bro-dev mailing list